Bug report #13499

Editing algorithm properties collapses input and output trees in Processing Modeler

Added by Anita Graser almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21544

Description

To reproduce:

  1. open a model
  2. expand the input and output trees of an algorithm
  3. edit the algorithm and press OK

--> the input and output trees collapse

This makes using the modeler quite annoying because the user has to always reexpand the trees.


Related issues

Related to QGIS Application - Bug report #9851: Processing - Toolbox tree view should not collapse when a... Closed 2014-03-24

Associated revisions

Revision 09f87c95
Added by Victor Olaya almost 5 years ago

[processing] remember params/outputs collapsed stated when editing alg in modeler

fixes #13499

History

#1 Updated by Victor Olaya almost 5 years ago

  • Status changed from Open to Closed

#2 Updated by Anita Graser almost 5 years ago

  • Status changed from Closed to Reopened

Sorry for the noise.

#3 Updated by Anita Graser almost 5 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF