Bug report #13498

Fix font size in Processing help windows on HiDPI displays

Added by Anita Graser about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21543

Description

The font of the help window content is too small on HiDPI displays to be readable, see attached screenshot

Screenshot_2015-10-03_16.05.53.png (48.6 KB) Anita Graser, 2015-10-03 07:09 AM


Related issues

Related to QGIS Application - Feature request #11103: Support for retina displays (HiDPI) Closed 2014-08-26

History

#1 Updated by Anita Graser about 5 years ago

  • Category changed from GUI to Processing/GUI

#2 Updated by Richard Duivenvoorde about 5 years ago

Hi Anita,

Can you be more precise about the fontsize? It looks not too wrong to me.

But as these help file come from the website, I think we should find out why this does not work in the website,
and probably add info to the css there.

how does a link like:

http://docs.qgis.org/testing/en/docs/user_manual/processing_algs/qgis/vector_analysis_tools.html#sum-line-lengths

look in your browser on your HiDPI display ?

#3 Updated by Anita Graser about 5 years ago

Sorry Richard, I cannot really be more precise than the screenshot shows. Compare the font size of the window title to the size of the help content. It's like a 5pt font on a normal (non-HiDPI screen) = pretty much unreadable.

The help looks fine in my web browser. (I assume because the browser takes care of things?) But the web view (?) in the Processing alg dialog does not scale things up :(

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.12)

#5 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Open to Feedback

Anita can you try with 716664e74939f3dd9ca531244e3b022b315d1e9e?

#6 Updated by Anita Graser almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Thanks, looks great now!

Also available in: Atom PDF