Bug report #13460

row_number function is twice listed in Field Calculator

Added by Harrissou Santanna almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Field calculator
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:21507

Description

In Field Calculator dialog, row_number function apprears twice : under "Variables" group and at the top level of the list.
master fea4ed9

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

It's intended behavior. Now certain functions or variables are highlighted and also shown in bold at the top of the list to make them stand out. It's only done with important ones in certain contexts.

#2 Updated by Harrissou Santanna almost 4 years ago

Thanks for the information, Nyall.
Does it mean that next time I open QGIS, there will be another function highlighted? And what are the other contexts it's done in (I opened many expression dialogs but couldn't find another highlighted function)?

#3 Updated by Nyall Dawson almost 4 years ago

It's not random, it will always show row_number as highlighted in the field calculator context. A few others which jump to mind are @value is highlighted for conditional formatting expressions, @grid_value and @grid_axis highlighted for custom grid annotation expressions. I think that's about it for now, but I'll likely add more as the need arises.

Also available in: Atom PDF