Bug report #13421

'split parts' tool deletes one of the two newly created parts

Added by Laurence Bechet almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21470

Description

Take any polygon shapefile. Use the split part tool on it. Only one half of the polygon remains (see video).

Recording__3.mp4 (248 KB) Laurence Bechet , 2015-09-24 09:32 PM

Polygon.zip - Test files (4.28 KB) Laurence Bechet , 2015-09-26 08:54 PM

Associated revisions

Revision 5de94447
Added by Nyall Dawson almost 4 years ago

Fix split parts tool only leaves one of the newly created parts (fix #13421)

History

#1 Updated by Saber Razmjooei almost 4 years ago

  • Category set to Digitising
  • Status changed from Open to Feedback

Can't reproduce. Could you share your example file?

#2 Updated by Laurence Bechet almost 4 years ago

Sure. Here they are.

#3 Updated by Saber Razmjooei almost 4 years ago

  • Affected QGIS version changed from 2.10.1 to master
  • Target version set to Version 2.12
  • Priority changed from Normal to Severe/Regression
  • Status changed from Feedback to Open

Same in master.

#4 Updated by Jürgen Fischer almost 4 years ago

  • File deleted (Recording__3.mp4)

#5 Updated by Jürgen Fischer almost 4 years ago

  • Status changed from Open to Feedback

Does that happen for any polygon for you? Works fine for me, but the polygon doesn't look like the one from the video.

#6 Updated by Laurence Bechet almost 4 years ago

Yes. My own files but also polygon files used at a training. I used the same set of files as the trainer who had Wien while I was using Pisa. Worked as expected for her not for me.

Checked again with another polygon file I found, on windows7, 64b with Pisa (2.10.1) QGIS code revision d20c5b7
and with 2.11.0-master QGIS code revision 3dcabfb

#7 Updated by Saber Razmjooei almost 4 years ago

  • Status changed from Feedback to Open

#8 Updated by Nyall Dawson almost 4 years ago

  • Assignee set to Nyall Dawson
  • Status changed from Open to In Progress

Ok, I can reproduce and have tracked this down. Working on a fix now.

#9 Updated by Nyall Dawson almost 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF