Bug report #13419

Creating spatial index on Shapefile with invalid geometries will make the layer disappear in map canvas when zooming and panning

Added by Laurence Bechet almost 5 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:21468

Description

I've got one file which behaves strangely when associated with a spatial index. When I zoom in, the layer disappears from the project and from any opened composers. If I remove the .qix file, the display is ok. If I re-create in qGIS the index (layer properties/Create spatial index) the layer goes back to its random behaviour.

spatialIndex.zip (20.2 KB) Laurence Bechet , 2015-09-26 08:50 PM

History

#1 Updated by Saber Razmjooei almost 5 years ago

  • Target version set to Version 2.12
  • Category set to Map Canvas
  • Priority changed from Normal to Severe/Regression
  • Affected QGIS version changed from 2.10.1 to master
  • Operating System deleted (windows)
  • OS version deleted (7 64bits)

Confirmed also in master. Works fine in 2.8.

#2 Updated by Salvatore Larosa almost 5 years ago

  • Status changed from Open to Feedback

I cannot reproduce here, please attach a small testcase.

#3 Updated by Laurence Bechet almost 5 years ago

I thought I have attached testcase. Anyway, here they are again.

#4 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Feedback to Open

#5 Updated by Salvatore Larosa almost 5 years ago

Thanks for the sample data.

I can confirm the issue although the attached testcase seems to have invalid geometries.

#6 Updated by Saber Razmjooei over 4 years ago

  • Subject changed from Shapefile with spatial index makes it disappear when zoomed in to Creating spatial index on Shapefile with invalid geometries will make the file disappear when zooming and panning

I can confirm that it doesn't happen with shapefile with correct geometries.

#7 Updated by Saber Razmjooei over 4 years ago

  • Subject changed from Creating spatial index on Shapefile with invalid geometries will make the file disappear when zooming and panning to Creating spatial index on Shapefile with invalid geometries will make the layer disappear in map canvas when zooming and panning

#8 Updated by Giovanni Manghi about 4 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

seems to work as expected on 2.14.3 and master, please reopen if necessary.

Also available in: Atom PDF