Bug report #13354

Digitizing "Fill ring" tool creates more features than needed

Added by Saber Razmjooei about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21407

Description

Hi,

Open a shapefile and toggle it to edition
Create a feature
with the advanced digitizing tool "Fill ring", create a new feature inside. You got 2 features in the canvas and the attribute table.
Create again a new feature with "fill ring" inside the last feature. Instead of 3 features, you got 4 either in canvas and attribute table.
The more you create "rings", the quicker features number increases (exponentially).

This bug has been reported in a french forum and the author has made a screencast (https://vid.me/y6SU) that says all (it occurs since 2.8, he says)

Associated revisions

Revision 45a6f715
Added by Nyall Dawson about 4 years ago

Fix fill ring tool creates more features than needed (fix #13354)

Revision 29e2b6a2
Added by Nyall Dawson almost 4 years ago

Fix fill ring tool creates more features than needed (fix #13354)

(cherry-picked from 45a6f715b3b980ea4ad0dce7e35aace041caac6d)

History

#1 Updated by Saber Razmjooei about 4 years ago

  • Subject changed from Bug report #13129] Digitizing "Fill ring" tool creates more features than needed to Digitizing "Fill ring" tool creates more features than needed

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF