Bug report #13353

QGIS and gdal 2.0.0

Added by John Evans over 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.10.1 Regression?:No
Operating System:Mac Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

Working through the training manual, I ran into trouble in section 14.7.3 attempting to "Join Attributes by Location". The resulting shapefile had far too few columns, having appeared to have applied the "mean" only to the X and Y columns of the join vector layer. When trying to investigate the join vector layer a bit further, I found that the Fiona package was unable to read it, and the maintainer's github site had gdal 2.0 compatibility as a known issue. As I use an up-to-date version of MacPorts, my 2.10.1 qgis installation was built on top of gdal 2.0.0.

When I backed gdal down to 1.11-1 and rebuilt qgis, the "join attributes by location" then worked as expected (and Fiona's "fio" command line utility was able to successfully dump the source shapefile's metadata as well).

The only ticket I found that seemed to raise the issue of gdal 2.0.0 was #12479, and it didn't quite seem to be the issue being encountered here, but I could be wrong.

History

#1 Updated by Saber Razmjooei almost 3 years ago

  • Status changed from Open to Feedback

Could you try with the latest master and report back?

#2 Updated by Even Rouault almost 3 years ago

  • Status changed from Feedback to Closed

I've just tested with QGIS master (on Linux) and GDAL 2.1. Works fine

Also available in: Atom PDF