Bug report #13312

The map canvas doesn't refresh correctly

Added by Harrissou Santanna about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21370

Description

I add a layer to my TOC and while canvas was refreshing, I toggle to invisible some of the layers. Doing all this so quickly leads to some artifacts in the canvas (some residue of a previous visible layer). see image attached.
The problem is that this artifacts remains in the canvas (however it doesn't appear in the map composer) whatever I do (set visible one by one the layers, set all of them visible/invisible, check the rendering box or not). It even moves/zoomes when I pan or zoom in/out the map canvas.

osgeo4w64 master 524716f

CanvasRefreshment.png (158 KB) Harrissou Santanna, 2015-09-02 03:48 AM

History

#1 Updated by Harrissou Santanna about 4 years ago

  • Status changed from Open to Closed

After some tests, it seems that it was due to "identified feature(s)" from a layer, even though I'm not sure there was an identified feature form opened or features listed in "Identify results" Panel. But selecting the identify tool and clicking in the canvas makes it disappear.
Closing this and will check if I can reproduce the issue with Identify tool.

Also available in: Atom PDF