Bug report #13299

Slow saving to network drive

Added by Jamie Portman almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Project Loading/Saving
Affected QGIS version:2.12.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21357

Description

Has anyone else experienced excessively slow saving of QGIS project files (not edited layers) when saving the project to a network drive?

We are noticing a 3-4MB project file will save almost instantaneously to the local C drive, but when saving to the network can take over 1 minute (you can literally watch the resulting file increase in size by about 100b/5secs).

I would normally say it must be network traffic/congestion or similar, however in file explorer we can drag-drop the same file (or much larger file) from the C drive to the same network location and it transfers almost immediately too... it is only slow when saving in QGIS directly.

Some kind of memory leak?


Related issues

Related to QGIS Application - Bug report #11211: Save QGIS project on VPN connection is very slow Closed 2014-09-16
Related to QGIS Application - Feature request #14460: Avoid corrupted qgs files when writing to network drives Open 2016-03-11

Associated revisions

Revision 4530c2ab
Added by Jürgen Fischer over 4 years ago

improve project saving to network shares (fixes #13299)

History

#1 Updated by Jakob Lanstorp over 4 years ago

I have the same problem with very slow save of a QGIS project on a network drive. Using the OSGEO4W QGIS 2.12.0.

#2 Updated by Gerhard Spieles over 4 years ago

Same problem with 2.10, win 7, 64bit

#3 Updated by Giovanni Manghi over 4 years ago

  • Category changed from Browser to Project Loading/Saving
  • Affected QGIS version changed from 2.10.1 to 2.12.0

For what I can remember saving on NFS/Samba shares was always ok for me, but I can give it a new try.

#4 Updated by Giovanni Manghi over 4 years ago

related to #11211?

#5 Updated by Jakob Lanstorp over 4 years ago

#11211 is the same problem as this issue.

This problem is due to how QGIS writes some of the files like project files and styles. A QGIS file is written in very small packages (7 bit I saw somewhere I cant find). Each package requires a control ping in return. Saving a 1 mb QGIS project file result in a large number of pings. My ping time for a 32 bytes package is 6 ms (pretty fast), but this adds up in time for a large project or style file. A 5 mb doc like MS WORD takes no time to save on a network, since they write larger packages.

#6 Updated by Jamie Portman over 4 years ago

Thanks Jakob....

Do you know if this something that could potentially be resolved in future releases?
ie. can it be made to write in larger packages like other software you mention?

#7 Updated by Carlos Lopez Quintanilla over 4 years ago

Same problem with 2.12, win7, 64bit.
when I save in localhost it takes 5 seconds, in network it delay more than 1 minute

#8 Updated by Giovanni Manghi over 4 years ago

see also #11211

#9 Updated by Giovanni Manghi over 4 years ago

Jakob Lanstorp wrote:

#11211 is the same problem as this issue.

This problem is due to how QGIS writes some of the files like project files and styles. A QGIS file is written in very small packages (7 bit I saw somewhere I cant find). Each package requires a control ping in return. Saving a 1 mb QGIS project file result in a large number of pings. My ping time for a 32 bytes package is 6 ms (pretty fast), but this adds up in time for a large project or style file. A 5 mb doc like MS WORD takes no time to save on a network, since they write larger packages.

Very interesting, could you please write your notes in the developers mailing list? thanks!

#10 Updated by Jürgen Fischer over 4 years ago

Giovanni Manghi wrote:

Very interesting, could you please write your notes in the developers mailing list? thanks!

See also https://bugreports.qt.io/browse/QTBUG-16715

#11 Updated by Jürgen Fischer over 4 years ago

  • Assignee set to Jürgen Fischer

#12 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed

#13 Updated by Jamie Portman over 4 years ago

Just tested and works perfectly!
Thanks.

Also available in: Atom PDF