Bug report #13232

Use estimated data in PG connection doesn't work

Added by Luca Lanteri almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21293

Description

It seems that the option "Use estimated data" in pg connection is ignored.
Qgis always use st_extent instead() of st_estimated_extent() when a new layer is loaded from PG.
It worked fine in 2.6.
Tested on 2.8 and 2.10

History

#1 Updated by Jürgen Fischer almost 5 years ago

Are there stats for the tables in question (see pg_stats)? QGIS only uses st_estimated_extent on analyzed tables.

#2 Updated by Luca Lanteri almost 5 years ago

I've done some other tests. The problem seems to be that I use INHERITS table. Pg_stats is correctly used for the child table but when I load the data from parent table they're ignored.

#3 Updated by Alessandro Pasotti over 4 years ago

  • Status changed from Open to Closed

This is not a bug in QGIS but in POstGIS, hopefully fixed upstream:

https://github.com/postgis/postgis/commit/92865ad6b0b3501a29e1575c9ef9ab89f23013a6

Also available in: Atom PDF