Bug report #13192

Error when saving Matplotlib figure

Added by Luca Congedo almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.10.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:21253

Description

I opened #13191 because I think it is a QGIS issue (or Matplotlib).
The plugin uses the Matplotlib framework for plotting, therefore I'd exclude that it is a plugin issue.
In QGIS 64bit, saving a plot to png format in the Semi-Automatic Classification Plugin causes the crash of QGIS 64bit. It works in Linux.
In QGIS 32bit, saving a plot to jpg format gives the error "The _imaging C module is not installed".
I think it is related to Matplotlib dependencies.
Attached the minidump.

Thank you

dump.zip (3.8 MB) Luca Congedo, 2015-08-06 11:38 AM

error.png (80.3 KB) Admire Nyakudya, 2015-09-15 12:05 AM

History

#1 Updated by Peter Drexel almost 5 years ago

I also get a minidump when I try to save a figure to png in the VoGIS-ProfilTool Plugin. It also uses the matplotlip.
Thanks
Peter

#2 Updated by Admire Nyakudya almost 5 years ago

When running a python script in processing that involves matplotlib.pyplot in windows 2.8 LTS saving a plot as png causes a mini dump error. However running the same processing script in linux results in no error. But saving the plot as jpg in windows does not result in error.

#3 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback

shouldn't this be filed on the osgeo4w tracker (where the dependencies and python libraries for Windows are packaged)?

#4 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

as far as I understand this could be an issue in matplotlib as is packaged in osgeo4w, if so please file a ticket in the osgeo4w bug tracker, if I'm wrong please reopen this ticket.

#5 Updated by Jean Hemmi over 4 years ago

I was following this issue since two users of my plugin (PhysiocapAnalyseur) have experimented the same error "The _imaging C module is not installed" when writing a png with matplotlib .

I have reproduced this error directly on an old eeepc 32 bit with a fresh install of QGIS 2.12.2 (
in the Console Python:

import PIL
from PIL import _imaging

finish with "DLL load failed" on Windows 32 bits where

matplotlib.__version__

'1.2.1'

PIL.Image.VERSION

'1.1.7'

It's OK on linux & Windows 64 bits where

matplotlib.__version__

'1.3.1'

PIL.VERSION

'1.1.7'

I've create a ticket on OSGEO bug tracker #481

#6 Updated by Jean Hemmi over 4 years ago

I've create a ticket on OSGEO4w bug tracker 481 https://trac.osgeo.org/osgeo4w/ticket/481

Also available in: Atom PDF