Bug report #13190

RuntimeError: module compiled against API version 9 but this version of numpy is 7

Added by Marco Lechner about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:2.8.3 Regression?:No
Operating System:openSUSE Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21252

Description

QGIS-2.8.3-ltr on openSUSE_13.1 returns an error on start: "RuntimeError: module compiled against API version 9 but this version of numpy is 7".
QGIS starts anyway bit the message reoccurs when trying to install e.g. Statist Plugin. In that case after the error message a second error pops up sayin that matplotlib is not installed (which indeed is numpy=1.7.1) and therefore the Plugin does not install.

Startting python from terminal sucesfully does:
$ import numpy
$ import matplotlib

History

#1 Updated by Alexander Bruy almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Looks like packaging issue in your distribution. Reopen if necessary

Also available in: Atom PDF