Bug report #13188

Please improve 'Missing dependency' error message

Added by Markus Neteler about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/GRASS
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:21250

Description

Using QGIS 2.10 on Linux (also elsewhere), does not let me run GRASS GIS 7 through processing any more.

The issue is likely that Processing searches for a specific name to start GRASS 7 ('grass', 'grass7', 'grass70', 'grass-7', ... who knows??) which is not present on the system as such.

Subsequently the following error message pops up but does not tell me what it was actually looking for:

Missing dependency. This algorithm cannot be run :-( 
This algorithm requires GRASS GIS 7 to be run. Unfortunately, it seems that GRASS GIS 7 is not installed in your system, or it is not correctly configured to be used from QGIS
Click here to know more about how to install and configure GRASS GIS 7 to be used with QGIS

Solution: include in the message the command string which failed (the hardcoded? name which Processing actually expects here so that the user can create a link to the true startup script name of GRASS 7). The current error message above is rather useless as such.

I tried to find the name Processing expects in the Python code but could not identify it.

A lot of people have this issue (see gis.stackexchange.com etc) but no clue how to solve it.

Associated revisions

Revision 75926f52
Added by Alexander Bruy almost 5 years ago

[processing] include GRASS path in the error message to make it more informative (fix #13188)

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Project changed from 78 to QGIS Application
  • Category deleted (59)

#2 Updated by Markus Neteler about 5 years ago

  • Affected QGIS version set to 2.10.1
  • Crashes QGIS or corrupts data changed from No to Yes

... I would be glad to know the GRASS startup script name Processing expects.

I tick again "Causes crash or corruption" because it simply doesn't work so far.

#3 Updated by Markus Neteler about 5 years ago

See also bug #13072

#4 Updated by Jürgen Fischer about 5 years ago

  • Category set to Processing/GRASS

#5 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Open to Closed

#6 Updated by Alexander Bruy almost 5 years ago

  • Resolution set to fixed/implemented

"Missing dependency" message was removed from Processing during UI/UX improvements. But I added GRASS path to the similar message, hope it helps.

Also available in: Atom PDF