Bug report #13161

GetLegendGraphics Server Error

Added by Uroš Preložnik over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:QGIS Server
Affected QGIS version:2.10.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21224

Description

With QGIS server update to 2.10 call to certain legend images with GetLegendGraphics causes 500 Server Error (polygon symbols seems OK).

Example URL: http://localhost/wms/eu_demo?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetLegendGraphics&FORMAT=image/png&BOXSPACE=1&LAYERSPACE=2&SYMBOLSPACE=1&SYMBOLHEIGHT=2&LAYERFONTSIZE=8&ITEMFONTSIZE=8&LAYERS=airports&DPI=96

It worked normally in 2.8.

This is from QGIS server log file:

[3309][21:03:55] No server python plugins are available
[3309][21:03:55] ************new request***************
[3309][21:03:55] remote ip: 127.0.0.1
[3309][21:03:55] HTTP_USER_AGENT: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
[3309][21:03:55] BOXSPACE:1
[3309][21:03:55] DPI:96
[3309][21:03:55] FORMAT:image/png
[3309][21:03:55] ITEMFONTSIZE:8
[3309][21:03:55] LAYERFONTSIZE:8
[3309][21:03:55] LAYERS:airports
[3309][21:03:55] LAYERSPACE:2
[3309][21:03:55] MAP:/home/uros/GIS/projects/eu_demo.qgs
[3309][21:03:55] REQUEST:GetLegendGraphics
[3309][21:03:55] SERVICE:WMS
[3309][21:03:55] SYMBOLHEIGHT:2
[3309][21:03:55] SYMBOLSPACE:1
[3309][21:03:55] VERSION:1.3.0

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from Normal to Severe/Regression
  • Target version changed from Version 2.10 to Future Release - High Priority

#2 Updated by Bernhard Ströbl over 4 years ago

Further information: On my WMS-Server (QGIS 2.10, Ubuntu 14.04) only polygon layers' legend graphics are displayed; any GetLegendGraphic request on a line or point layer results in a 500 error.
my Server: http://jena.de/kartenportal

#3 Updated by Tudor Bărăscu about 4 years ago

I also encountered this issue in QGIS Master.
If someone wants to replicate it, you can download the VM described at http://qgep.github.io/docs/vm/index.html and run the following request

http://qgisplatform.demo/wms/qgep_en?SERVICE=WMS&VERSION=1.3.0&SLD_VERSION=1.1.0&REQUEST=GetLegendGraphic&FORMAT=image/png&LAYER=vw_qgep_cover&STYLE=

#4 Updated by Tom Palan about 4 years ago

I can confirm this bug with Version 2.10.0 on Linux (Debian Jessie AMD64). Apparently there is a segfault when requesting GetLegendGraphics.

#5 Updated by Marco Hugentobler about 4 years ago

I have tested it, and it seems to be an x-server problem (seems some changes in legend rendering now trigger the need for an X-Server).

#6 Updated by Uroš Preložnik about 4 years ago

Marco Hugentobler wrote:

I have tested it, and it seems to be an x-server problem (seems some changes in legend rendering now trigger the need for an X-Server).

What does that mean, can with certain configuration this work? Will this be fixed in next release?

thanks,
Uros

#7 Updated by Jürgen Fischer about 4 years ago

  • Subject changed from QGIS Server GetLegendGraphics Server Error to GetLegendGraphics Server Error

#8 Updated by Tom Palan about 4 years ago

I compiled Debian packages from yesterdays (2015-10-07) git master, and it seems that the error is gone. But I also had to install 3 more packages to my system (new dependencies): libqca2 libqwt5-qt4 libqca2-plugin-ossl. Maybe this fixed the error?

#9 Updated by Jürgen Fischer about 4 years ago

Tom Palan wrote:

I compiled Debian packages from yesterdays (2015-10-07) git master, and it seems that the error is gone. But I also had to install 3 more packages to my system (new dependencies): libqca2 libqwt5-qt4 libqca2-plugin-ossl. Maybe this fixed the error?

Probably not. libqca2 and libqca2-plugin-ossl are for the new authentication system - that has been around in master for two weeks tops. And libqwt5-qt4 shold not be now - but even if it was, IIRC it's only used to display histograms and the GPS information widget. So that should be unrelated too and it must be something else.

#10 Updated by Tudor Bărăscu about 4 years ago

  • Status changed from Open to Closed

I also tested and the issue is indeed gone.

Also available in: Atom PDF