Bug report #13145

An error occurred when executing the query. The data provider said: no result buffer

Added by baditaflorin - over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:2.10.0 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21208

Description

error when wanting tho changes a Postgis filtered output with another in Qgis 2.9

advanced_filter_its_working.PNG (211 KB) baditaflorin -, 2015-08-20 12:54 AM

anything_i_put.png (193 KB) baditaflorin -, 2015-08-20 12:57 AM

qgis_2_8_2_working.PNG (424 KB) baditaflorin -, 2015-08-20 01:18 AM

History

#1 Updated by Jürgen Fischer over 5 years ago

More output in the log? Can you come up with a reproducable example?

#2 Updated by Giovanni Manghi over 5 years ago

  • Category set to Data Provider/PostGIS
  • Status changed from Open to Feedback

#3 Updated by baditaflorin - over 5 years ago

Can confirm the same error on Qgis 2.10

How do i access the log ? It`s not intuitive and i cannot find it

#4 Updated by baditaflorin - over 5 years ago

Via Filter it`s not working, but if i use the advanced Filter it is working.

#5 Updated by baditaflorin - over 5 years ago

the bug affect the Query builder by default, does not matter what i write, it`s a Postgis layer that you have loaded ? Then you will get the

The data provider said :
No result buffer

Still cannot find from where to access the log

#6 Updated by Jürgen Fischer over 5 years ago

baditaflorin - wrote:

the bug affect the Query builder by default, does not matter what i write, it`s a Postgis layer that you have loaded ? Then you will get the

The data provider said :
No result buffer

Still cannot find from where to access the log

The grey bubble on the bottom right in the status bar (used to be a warning sign with notifications on new messages).

#7 Updated by baditaflorin - over 5 years ago

Qgis 2.10 does not have a log file anymore, from what i have seen

Opened a new ticket here #13239

I will update on this topic using Qgis 2.8.2 , because that version it`s not affected by this regression

#8 Updated by baditaflorin - over 5 years ago

If you want to replicate

Step 1 : Load a Postgis layer
Step 2 : right click on the layer > click Filter
Step 3 : Write anything that you want and click Ok

#9 Updated by Jürgen Fischer over 5 years ago

baditaflorin - wrote:

If you want to replicate

Step 1 : Load a Postgis layer
Step 2 : right click on the layer > click Filter
Step 3 : Write anything that you want and click Ok

Did you click on the bubble yet?

#10 Updated by baditaflorin - over 5 years ago

Tested in Qgis 2.8.2 and it`s working.

So it`s a 2.9 / 2.10 error.

#11 Updated by baditaflorin - over 5 years ago

  • Target version deleted (Version 2.10)

This seems to be fixed in Qgis 2.11 Master Build 16d7a06

#12 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Also available in: Atom PDF