Bug report #13144

Style Categorized not working with PostGis database

Added by baditaflorin - over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:21207

Description

I have a database with around 200.000.000 points, where i filtered only 2.800.000 points.

I am trying to Style them based on a attribute.

When i click on Classify, nothing happens.

I also looked at pg_stat_activity and QGIS it`s not even trying to do a query and return a result.

Capture_2_8_2.PNG - In qgis 2.8.2 it is working (10.4 KB) baditaflorin -, 2015-07-23 01:50 AM

Capture_2_9.PNG - 2.9 output (91.4 KB) baditaflorin -, 2015-07-23 01:51 AM

Capture_pgadmin2_9.PNG - 2.9 pgadmin - nopthing happens (9.96 KB) baditaflorin -, 2015-07-23 01:51 AM

History

#1 Updated by baditaflorin - over 4 years ago

This seems like a regression, tested in 2.8.2 and it`s working.

#3 Updated by baditaflorin - over 4 years ago

I have this problem also in 2.8.2 with ways

there is a hard coded limit atfer that QGIs fails directly ?

We should announce to the users then.

#4 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Feedback

Any output in the log?

#5 Updated by baditaflorin - over 4 years ago

  • Target version deleted (Future Release - High Priority)

I think the problem it`s because i am using a view to see the 2.800.000

#6 Updated by Giovanni Manghi over 4 years ago

  • Category set to Symbology

baditaflorin - wrote:

I think the problem it`s because i am using a view to see the 2.800.000

so you are trying to categorize a 2.8M records view from a 200M records dataset, stored on postgis?

what dataset is? what attribute are you using?

#7 Updated by Giovanni Manghi about 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Jürgen Fischer wrote:

Any output in the log?

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF