Bug report #13143

Print Composer won't export PDF

Added by Ronald Campbell almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.8.2 Regression?:No
Operating System:Mac Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21206

Description

Newly installed QGIS 2.8.2 on laptop running Mac OS 10.10.2. Created 5-layer map. Composed layout with legend, label in Composer. When attempting to export PDF, saw brief flash where "export" box should have been; no export occurred. Repeated attempts to quit, re-start over past two days. One successful export of JPEG after many failures. Also tried, failed to print to paper.

With older versions of QGIS, I have been able to print to paper, to PDF and to JPEG.


Related issues

Related to QGIS Application - Bug report #13399: Unable to export image in Print Composer while Render as ... Closed 2015-09-22

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

Coukd you attach the a sample project and data? Does the issue persist on 2.10? have you tried without any 3rd party plugin active? Have you tried by (temporarily) purging the .qgis2 folder?

#2 Updated by Miguel Martinez Soler over 4 years ago

Actually it won't export an image neither. I found the same issue on 2.10.

It seems its related to the HTML rendering of labels. I've recorded a screencast that can be seen at https://youtu.be/C2QZX9iSYe8
If I uncheck the "Render as HTML" option, everything works ok. The exporting dialog does work actually from time to time, even if I use HTML rendering.

I'll check this again on 2.10 and upload a video later.

#3 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

duplicate of #13399

Also available in: Atom PDF