Bug report #13130

"Zoom last" zooms to last zoom level but centers around current center

Added by Casper Børgesen over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21194

Description

The Zoom last functionality seems to haved changed.

Situation A:
I have a view of the entire area.

Situation B:
I have zoomed into a small area close to the edge of the bounding box of A.

Situation C:
I have used Zoom last to go back to A.

Result:
I have the zoom level of A but the bounding box is centered around the bounding box of B. I would expect the bounding box to be equal to that of A, which was the behavior of 2.10 and below.

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Which revision are you testing with?

#2 Updated by Casper Børgesen over 4 years ago

Nyall Dawson wrote:

Which revision are you testing with?

Its master f3fe29d from osgeo64w.

#3 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Duplicate of #13095

Also available in: Atom PDF