Feature request #13109

Default values in forms

Added by didier peeters almost 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Forms
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

There should be a possibility to set default values in the form. From a discussion on Qgis-user it appears that we should have the possibility to set a default value in the form design, and decide if it precedes or not the previous value entered.
IMO, by default the default values precede the last inserted values (otherwise defining default values would be somehow useless), except where specified otherwise in the field definitions. So there would be an option in each field definition (a checkbox, next to the default value definition field) stating that the last non null inserted values do precede the default one. But others consider that the last value should have precedence.
In any case this should be set at the level of the field. I don't know if it should also be possible to specify in this order of precedence the default values provided by the database (i.e. when using a layer stored in PostgreSQL).

I added this point also here : https://github.com/qgis/QGIS-Enhancement-Proposals/pull/13

History

#1 Updated by Jürgen Fischer almost 2 years ago

  • Subject changed from Default vaues in Forms to Default values in forms

#2 Updated by Nyall Dawson about 1 year ago

  • Status changed from Open to Closed

Duplicate of #12492

Also available in: Atom PDF