Bug report #13098

GeoJSON vector issue

Added by Lucas Barbosa Cavalcante Cavalcante almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.10.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:21164

Description

Quando abro o QGIS e tendo abrir um arquivo vetorial em GeoJSON, ele simplesmente não abre da forma correta, se o arquivo tem por exemplo 300 pontos ele abre 2, a tabela de atributos mantém os 300. Percebi que o erro não ocorre caso eu importe um shp, por exemplo, converta ele para geojson e depois abra novamente meu arquivo, ele abre normal.

10.png - Erro que ocorre assim que tento abrir o GeoJSON quando abro o QGIS (372 KB) Lucas Barbosa Cavalcante Cavalcante, 2015-07-09 05:06 AM

teste.geojson - file for test (27.8 KB) Lucas Barbosa Cavalcante Cavalcante, 2015-07-10 05:38 PM


Related issues

Duplicates QGIS Application - Bug report #11587: all coordinates truncated to integer values when system h... Closed 2014-11-06

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Please file tickets in english. Regarding your problem please attach sample data to allow us replicate the problem, obrigado!

#2 Updated by Lucas Barbosa Cavalcante Cavalcante almost 5 years ago

  • Status changed from Closed to Reopened
  • File teste.geojson added

When I open the QGIS and try to open a vector file in GeoJSON , it just does not open correctly , if the file has for example 300 points it opens 2, the attribute table keeps 300. I realized that the error does not occur if I care one shp , for example , convert it to GeoJSON and then open again my file , it opens normal.

#3 Updated by Giovanni Manghi almost 5 years ago

  • Priority changed from High to Normal
  • Resolution deleted (invalid)
  • Status changed from Reopened to Feedback
  • Category set to Vectors
  • Subject changed from GeoJSON com problema de visualização to GeoJSON vector issue

Lucas Barbosa Cavalcante Cavalcante wrote:

When I open the QGIS and try to open a vector file in GeoJSON , it just does not open correctly , if the file has for example 300 points it opens 2, the attribute table keeps 300. I realized that the error does not occur if I care one shp , for example , convert it to GeoJSON and then open again my file , it opens normal.

you must also write the title in English.

The file you attached has 64 points, and they all show in the map, and as well in the attribute table. Where is the issue?

#4 Updated by Lucas Barbosa Cavalcante Cavalcante almost 5 years ago

  • Target version set to Version 2.10
  • Assignee set to Giovanni Manghi

Recalling that the operating system I use which QGIS is presenting this error which can be seen in the image 10.png that have attached to the call , is Ubuntu 14.04 LTS x64. Already detected that the problem does not occur in windows .

#5 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.10)
  • Assignee deleted (Giovanni Manghi)

I also use Ubuntu 14.04 64 bit.

What error should I see in the attached screenshot? What is in the screenshot is related to the attached sample data?

Note:
prefere explicar em Português (não neste bug tracker, mas escrevendo para mim de forma particular)?

#6 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback. Reopen if necessary.

#7 Updated by Martin Weis over 4 years ago

This is a duplicate of #11587

Also available in: Atom PDF