Feature request #1306

Attribute table display problem when features already selected

Added by cfarmer - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Vectors
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11366

Description

If a vector layer has features selected before opening it's attribute table, only those features previously selected are visible when the attribute table is opened.

bugfix1306.diff Magnifier (5.22 KB) Jürgen Fischer, 2008-09-10 02:14 PM

History

#1 Updated by Jürgen Fischer about 12 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

That's intentional.

#2 Updated by Maciej Sieczka - about 12 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (invalid)

Replying to [comment:2 jef]:

That's intentional.

I also noticed the issue cfarmer reported and thought it was an error. Now that I learned it's intentional I find it at least counter intuitive.

Why not, instead, only navigate to the selected row, still leaving the rest of the table visible? As it is now, users will ask where has their data gone.

#4 Updated by Maciej Sieczka - about 12 years ago

Confusing the user is not the way to solve performance issues with big tables IMO.

#5 Updated by Jürgen Fischer about 12 years ago

Now the behaviour is configurable. The attribute table either shows all featues (default), all selected features or all features in the current canvas.

#6 Updated by Jürgen Fischer almost 12 years ago

newly selected features that are not present in the attribute table are now added.

#7 Updated by Jürgen Fischer almost 12 years ago

in 227f3814 (SVN r9599) that is.

#8 Updated by Paolo Cavallini almost 12 years ago

I still have problems with this: once the table with selected elements is shown, how can a user select all the rows? Apparently pressing the first button has no effect

#9 Updated by Jürgen Fischer almost 12 years ago

Replying to [comment:6 jef]:

Now the behaviour is configurable. The attribute table either shows all featues (default), all selected features or all features in the current canvas.

Replying to [comment:9 pcav]:

I still have problems with this: once the table with selected elements is shown, how can a user select all the rows? Apparently pressing the first button has no effect

The patch is still pending due to feature freeze. Once it's applied your your problem would be solved, wouldn't it?

#10 Updated by Martin Dobias almost 12 years ago

I think that the current behaviour is not acceptable for most users. Showing only selected rows is quite misleading (without telling user what's going on). It introduces new problems and it doesn't solve the real problem.

I vote for applying the patch before 1.0.

#11 Updated by Marco Hugentobler almost 12 years ago

Well, the solution for the real problem would be 'better table' I guess.
Looking closer at the patch, it seems quite unproblematic bug wise. Still we need to have the ok from the documentation team since it involves GUI changes.
And translations are also not aware of the additional string.

#12 Updated by Marco Hugentobler almost 12 years ago

I checked with Otto and it seems to be ok for the documentation team.
Jürgen, could you please apply the patch? It seems that it needs some small changes to apply it to current svn trunk.

Thanks,
Marco

#13 Updated by Jürgen Fischer almost 12 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

applied in 43659ad8 (SVN r9690)

#14 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF