Bug report #13058

Remove internal OWSlib copy

Added by Paolo Cavallini over 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21128

Description

Curently we maintain an internal, old copy of OWSlib in the MetaSearch plugin (now core). Te lib is more up to date on Deb (which fixes a current bug in MS).
I suggest to use the shared lib.
This will require to add dependencies for major platforms.

History

#1 Updated by Emmanuel Blondel about 5 years ago

Is there any news about this requirement?
PS: For some reason the original ticket where we exchanged on this (with the test case of FAO Geonetwork), and where i have described the issue doesn't exist anymore (#12404) Is there a new linking? or has it been removed (!) ?

#2 Updated by Tom Kralidis about 5 years ago

No movement on this issue yet. For reference/explanation, see this discussion

I think the issue here is maintaining OWSLib in OSGeo4W and the other supported builds. We need to ensure there is an OWSLib packaging effort foreach of these.

P.S. we have moved all MetaSearch tickets into the main QGIS tracker. MetaSearch is now a category and related issues have been moved to https://issues.qgis.org/projects/quantum-gis/issues?category_id=107&set_filter=1&status_id=o

#3 Updated by Emmanuel Blondel almost 4 years ago

Hello, is there any news for this blocking bug? It would be good, at least, to have a workaround for this.
Thanks in advance

#4 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#5 Updated by Paolo Cavallini over 2 years ago

  • Status changed from Open to Feedback
  • Description updated (diff)

This seems to be fixed: Tom, could you confirm?

#6 Updated by Tom Kralidis over 2 years ago

Looks okay from here.

#7 Updated by Paolo Cavallini over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF