Bug report #13058

Remove internal OWSlib copy

Added by Paolo Cavallini about 2 years ago. Updated 5 months ago.

Status:Open
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

Curently we maintain an internal, old copy of OWSlib in the MetaSearch plugin (now core). Te lib is more up to date on Deb (which fixes a current bug in MS).
I suggest to use the shared lib.
This will require to add dependencies for major platforms.

History

#1 Updated by Emmanuel Blondel about 2 years ago

Is there any news about this requirement?
PS: For some reason the original ticket where we exchanged on this (with the test case of FAO Geonetwork), and where i have described the issue doesn't exist anymore (#12404) Is there a new linking? or has it been removed (!) ?

#2 Updated by Tom Kralidis about 2 years ago

No movement on this issue yet. For reference/explanation, see this discussion

I think the issue here is maintaining OWSLib in OSGeo4W and the other supported builds. We need to ensure there is an OWSLib packaging effort foreach of these.

P.S. we have moved all MetaSearch tickets into the main QGIS tracker. MetaSearch is now a category and related issues have been moved to https://issues.qgis.org/projects/quantum-gis/issues?category_id=107&set_filter=1&status_id=o

#3 Updated by Emmanuel Blondel 10 months ago

Hello, is there any news for this blocking bug? It would be good, at least, to have a workaround for this.
Thanks in advance

#4 Updated by Giovanni Manghi 5 months ago

  • Easy fix? set to No
  • Regression? set to No

Also available in: Atom PDF