Bug report #1304

Image export dialog uses wrong file name on changing image type

Added by cmoe - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11364

Description

The image export dialog in the print composer opens always with the last file exported as suggestion (eg. 'foo.tif'). If I am changing the image type now, let's say to a png, the file name field says 'foo.png'. This is correct, but if I save it now, the file name will be still 'foo.tif'.

I guess, the problem is, that the focus all the time lays on the last suggestion in the file/directory part of the dialog, where this last suggestion ('foo.tif') is marked.

It works if I write anything in the file name field (e.g. delete the 'g' on 'foo.png' and add it again). Also the 'foo.tif' isn't marked any longer.

History

#1 Updated by Marco Hugentobler about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

A fix for this is in 8552d60b (SVN r9300)

#2 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF