Feature request #13021

HTML labelling in map window

Added by Jochen Huber almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:21097

Description

It would be great to be able to use HTML rendering for map labels. This is already supported in composer and the expression editor shows HTML formating in the preview when editing map label expressions, however, for map labels this is not rendered as HTML.

Example use case:
We regularly have to create maps showing contamination levels in groundwater. Each well has a multiline label with the well number on the first line and the measured contaminant concentration on the second line. With HTML rendering, it would be possible to
- write the well numbers in italics if the well is in the second aquifer
- color the contamination values in red if they are above the threshold.

History

#1 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #4080

Also available in: Atom PDF