Bug report #12949

Problem When Doing Intersect

Added by Adi Kurniawan almost 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.8.1 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21029

Description

Hi all,

I've a problem when I try to intersect two files (files attached), the result has some empty area.
This is the chronology:
1. I do intersect 2 files like at the picture.

2. But the result, have some empty area.

3. When I check the geometry, apparently there is a geometry error

4. I do zoom in the map to the error indication zone until 1:1 scale, the geometry showed like at the picture

5. I enter to the editor mode to see the node. I click using the node tool and separate them, apparently there are 4 nodes in there

And the polygon in left and right side is one polygon

FYI, I've been tried this file to process in ArcMap, there is no error, and the result is good.

7. When I try to modification this file like in the picture, then I doing intersect again, the result is good.

My question is
a. What is the type of geometry error of this?
b. Is the error process cause by geometry error or QGIS bug, because when I try the same file in ArcMap, the result is good?
c. If this is just a geometry error, what the best step that must I do, besides that I do in the step in number 7?

Thank you.

Regard,

Intersect.zip (2.59 MB) Adi Kurniawan, 2015-06-12 05:10 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Assignee deleted (Tim Sutton)
  • Category changed from Browser to 44
  • Status changed from Open to Feedback

duplicate of #11986 ?

meanwhile I'll bet that if you the same operation with the v.overlay tool in the qgis/Processing toolbox you'll get the right results.

#2 Updated by Giovanni Manghi almost 5 years ago

meanwhile I'll be that if you the same operation with the v.overlay tool in the qgis/Processing toolbox you'll get the right results.

yep, just tested. And also the tool "polygon intersection" always in processing, returns the right results.

#3 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

duplicate of #11986

#4 Updated by Tim Sutton almost 5 years ago

Hi Giovanni

I tried to show him to use v.overlay, but unfortunately QGIS package from ubuntugis is not working with GRASS package. Ubuntugis currently provides QGIS 2.8.1 and GRASS 7 and although grass 7 is enabled in processing options etc. All processing commands currently fail with 'grass could not be found'. Guess we need to wait for Radim's patched version of GRASS to land?

Regards

Tim

#5 Updated by Giovanni Manghi almost 5 years ago

Tim Sutton wrote:

Hi Giovanni

I tried to show him to use v.overlay, but unfortunately QGIS package from ubuntugis is not working with GRASS package. Ubuntugis currently provides QGIS 2.8.1 and GRASS 7 and although grass 7 is enabled in processing options etc. All processing commands currently fail with 'grass could not be found'. Guess we need to wait for Radim's patched version of GRASS to land?

Regards

Tim

Hi Tim,
please check in the general Processing options (under "providers") if GRASS 7 is active. GRASS 7 is already working with Processing and is not dependent on the work being done on the QGIS/GRASS plugin.

Please let me know if it works

cheers!

#6 Updated by Jürgen Fischer almost 5 years ago

Tim Sutton wrote:

Hi Giovanni

I tried to show him to use v.overlay, but unfortunately QGIS package from ubuntugis is not working with GRASS package. Ubuntugis currently provides QGIS 2.8.1 and GRASS 7 and although grass 7 is enabled in processing options etc. All processing commands currently fail with 'grass could not be found'. Guess we need to wait for Radim's patched version of GRASS to land?

Use our repositories (with the ubuntugis repository for dependencies) for QGIS 2.8.2 (see QGIS Installers Debian/Ubuntu). We don't upload to launchpad anymore - the ubuntugis packages are created as any other debian packages.

#7 Updated by Adi Kurniawan almost 5 years ago

Giovanni Manghi wrote:

Tim Sutton wrote:

Hi Giovanni

I tried to show him to use v.overlay, but unfortunately QGIS package from ubuntugis is not working with GRASS package. Ubuntugis currently provides QGIS 2.8.1 and GRASS 7 and although grass 7 is enabled in processing options etc. All processing commands currently fail with 'grass could not be found'. Guess we need to wait for Radim's patched version of GRASS to land?

Regards

Tim

Hi Tim,
please check in the general Processing options (under "providers") if GRASS 7 is active. GRASS 7 is already working with Processing and is not dependent on the work being done on the QGIS/GRASS plugin.

Please let me know if it works

cheers!

Hi Giovanni,

The setting that you mean is this?

#8 Updated by Giovanni Manghi almost 5 years ago

Hi Giovanni,

The setting that you mean is this?

yes, but if you are on Linux and using repositories to install packages then you will have only GRASS7 or GRASS installed (likely GRASS7 if you are on a recent release of Ubuntu): uncheck the version you have not installed.

#9 Updated by Adi Kurniawan almost 5 years ago

Giovanni Manghi wrote:

Hi Giovanni,

The setting that you mean is this?

yes, but if you are on Linux and using repositories to install packages then you will have only GRASS7 or GRASS installed (likely GRASS7 if you are on a recent release of Ubuntu): uncheck the version you have not installed.

Hi,

I've tried to do this process in my windows computer.
I just could try the v.overlay process that available in GRASS Commands, because when I use the v.overlay process in GRASS 7 Commands, there is an error notification

And also, when I use the v.overlay in GRASS Commands, I could use it

But there is a problem in the result

#10 Updated by Giovanni Manghi almost 5 years ago

I've tried to do this process in my windows computer.
I just could try the v.overlay process that available in GRASS Commands, because when I use the v.overlay process in GRASS 7 Commands, there is an error notification

if you used the Standalone installer this ships with GRASS 6.4 so it is normal you have to configure Processing to use it instead of GRASS 7.

And also, when I use the v.overlay in GRASS Commands, I could use it
But there is a problem in the result

you are hitting an issue that depends on the limited capacity that shapefiles have for column names length:

in your inputs shapefiles you have columns with similar/identical columns names. The operation will produce an output with column names with a prefix a_ or b_ and together with the 10 char length limit this will produce a shape with a few columns with identical names, and that is not allowed.
If you change the proper column names in your inputs then the operation goes well.

#11 Updated by Adi Kurniawan almost 5 years ago

Giovanni Manghi wrote:

I've tried to do this process in my windows computer.
I just could try the v.overlay process that available in GRASS Commands, because when I use the v.overlay process in GRASS 7 Commands, there is an error notification

if you used the Standalone installer this ships with GRASS 6.4 so it is normal you have to configure Processing to use it instead of GRASS 7.

And also, when I use the v.overlay in GRASS Commands, I could use it
But there is a problem in the result

you are hitting an issue that depends on the limited capacity that shapefiles have for column names length:

in your inputs shapefiles you have columns with similar/identical columns names. The operation will produce an output with column names with a prefix a_ or b_ and together with the 10 char length limit this will produce a shape with a few columns with identical names, and that is not allowed.
If you change the proper column names in your inputs then the operation goes well.

Hi Giovanni,

Thanks for advise me about the column names.
I've tried to delete the column with similar names in both of the files, and the process could running in v.overlay that available at GRASS Commands.
When I put the SS_Agroklimat data as input layer (A), the result is fine.

But, when I put the SS_Geo data as input layer (A), the result still have an empty area.

#12 Updated by Giovanni Manghi almost 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF