Bug report #1291

Composer legend items are duplicated after update

Added by Horst Düster about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11351

Description

1. Load a legend to composer canvas

2a. Select legend and click button update all

3. as the result the whole legend is duplicated

History

#1 Updated by Marco Hugentobler about 12 years ago

I cannot reproduce this with the newest svn version (tested with Qt 4.3.4 and 4.4.1). Is there anything I have to do in addition to the three steps to get a duplicated legend?

#2 Updated by Marco Hugentobler about 12 years ago

I found and fixed (in ca0eb5c5 (SVN r9278)) a problem where the classification items have been duplicated after pressing 'update'. Was this what you meant?

#3 Updated by Horst Düster about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Replying to [comment:2 mhugent]:

I found and fixed (in ca0eb5c5 (SVN r9278)) a problem where the classification items have been duplicated after pressing 'update'. Was this what you meant?

in 911038bb (SVN r9282) it seems to be solved. I close this ticket. Many thanx to Marco!

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF