Bug report #12887

customization: ini file saved without extension == invisible when trying to open

Added by Richard Duivenvoorde about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Customisation Framework
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20977

Description

Playing with cusomization here: saving a QGIS setup which only can open shape file.

I saved the setup as 'minimalshape' (as I did not know which extension was needed).
Trying to open that file again via 'open customization file', it was not visible anymore (because the file-filter for the dialog is .ini and there is no option for 'all files'

Proposed fixes(?):
- add .ini when the user does not add it him/herself ot a config file
- add '(.ini)' to the visible string in the 'filter dropdown' in the file browser?
- maybe also add a 'all files' as file filter so at least I can see the file I just saved

Associated revisions

Revision aa417a10
Added by Alexander Bruy over 4 years ago

add extension when saving customization file (fix #12887)

History

#1 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Closed

#2 Updated by Alexander Bruy over 4 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF