Bug report #12851

Delete ring tool broken

Added by Nyall Dawson over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20944

Description

The new geometry engine has broken use of the delete ring tool. I suspect the issue is in QgsGeometryEditUtils::deleteRing, as the routine breaks out if the geometry is not a QgsMultiSurfaceV2. This routine needs to handle geometry collections too (eg multipolygons).

Associated revisions

Revision cde749f1
Added by Nyall Dawson over 5 years ago

Fix broken delete ring tool (fix #12851)

History

#1 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF