Bug report #12844

qgis master: python error opening SQL console in DB Manager

Added by Giovanni Manghi over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20939

Description

Traceback (most recent call last):
  File "/usr/share/qgis/python/plugins/db_manager/db_manager.py", line 189, in runSqlWindow
    from dlg_sql_window import DlgSqlWindow
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/db_manager/dlg_sql_window.py", line 43, in 
    from .ui.ui_DlgSqlWindow import Ui_DbManagerDlgSqlWindow as Ui_Dialog
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/usr/share/qgis/python/plugins/db_manager/ui/ui_DlgSqlWindow.py", line 238, in 
    import resources_rc
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: No module named resources_rc

Associated revisions

Revision 6524080f
Added by Salvatore Larosa over 4 years ago

[db manager] Fix #12844 - python error opening SQL Window

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Feedback

Not reproducable with 1:2.9.0+git20150601+15ba006

#2 Updated by Saber Razmjooei over 4 years ago

Still appears in f1817d0.

#3 Updated by Nathan Woodrow over 4 years ago

Do you have a clean build? I don't see that here

#4 Updated by Giovanni Manghi over 4 years ago

Nathan Woodrow wrote:

Do you have a clean build? I don't see that here

yes, clean installations on both linux and windows. Still see the issue on the latest master installed with osgeo4w/nightly-build repo.

#5 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

#6 Updated by Saber Razmjooei over 4 years ago

yes, on a clean build from source.

#7 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Feedback

Odd. Works for me with qgis-dev from OSGeo4W (2.9.0-88, 64bit or 2.9.0-85, 32bit, both e295c1f) and from a nightly build (ie 1:2.9.0+git20150601+15ba006 on unstable) and from a fresh build ran from the build directory.

#8 Updated by Salvatore Larosa over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF