Bug report #1284

fonts are garbled

Added by Maciej Sieczka - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11344

Description

Debian amd64, QT 4.4.0, SVN r9254.

The old issue with fonts in map composer strikes back. See the attached screendump. The font for "Legenda" is supposedly Arial 24. Obviously something's wrong.

print_fonts_broken.png - garbled fonts in legend's title (6.64 KB) Maciej Sieczka -, 2008-09-04 09:05 AM

History

#1 Updated by Marco Hugentobler about 12 years ago

Seems that I have to apply Stevens font bug workaround in new composer.

#2 Updated by Maciej Sieczka - about 12 years ago

Not sure if the same issue. Looks related though:

Sans Serif font (the default in legend, scalebar etc.) is always rendered blocky (both in the output and the composer itself), like if it was rasterized. Changing the font to any other fixes that. Changing it back to Sans Serif brings the issue back.

#3 Updated by Marco Hugentobler about 12 years ago

Does cde4f741 (SVN r9266) fix these issues?

#4 Updated by Maciej Sieczka - about 12 years ago

Replying to [comment:3 mhugent]:

Does cde4f741 (SVN r9266) fix these issues?

Seems fixed. A new issue - I can't change the Sans Serif font size (other font properties change OK though). All other fonts chnage their size OK. Weird.

#5 Updated by Marco Hugentobler almost 12 years ago

This sounds strange. I tested with current svn head (dcaaea9f (SVN r9749)) and Qt 4.4.2 and changing the sans serif font size worked. I tested that with composer label, composer legend and composer scalebar.
Please test if this bug is still present for you.

Marco

#6 Updated by Maciej Sieczka - almost 12 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

The problem is gone for me too (QT 4.4.3). Closing it.

#7 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF