Bug report #12828

QGIS Crash when using composer and Windows Print Spooler is not running

Added by Andy Harney about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.8.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20923

Description

Hi,

Attempting to alter the page setup of a print composer, I'm hit with an immediate crash and minidump.
This occurs both with and without an empty layout.

Thanks.

qgis-20150526-184309-2528-6916-1b929ef.zip - Composer Crash (3.86 MB) Andy Harney, 2015-05-26 12:25 PM

Capture.PNG (7.39 KB) Andy Harney, 2015-05-26 12:42 PM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

please attach a sample project/data.

#2 Updated by Andy Harney about 5 years ago

The crash occurs on a brand new, empty project, without any data added.

#3 Updated by Giovanni Manghi about 5 years ago

Andy Harney wrote:

The crash occurs on a brand new, empty project, without any data added.

(backup and) remove .the qgis2 folder, restart qgis and try again.

#4 Updated by Andy Harney about 5 years ago

I've found the cause, if the Windows service "Print Spooler" is not running when QGIS starts, QGIS will crash.
However, if the service is running when QGIS starts, but stopped whilst QGIS is still open, QGIS will display the following,

Not sure why the service had been stopped in my case, but I guess QGIS crashing outright isn't intended.

Thanks.

#5 Updated by Giovanni Manghi about 5 years ago

  • Subject changed from Crash - Composer - Page Setup to QGIS Crash when using composer and Windows Print Spooler is not running
  • Status changed from Feedback to Open
  • OS version deleted (8.1 (x64))
  • Target version set to Future Release - Lower Priority
  • Priority changed from Normal to Low

#6 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Feedback

Can you test with 2.12? I think this should be fixed now...

#7 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

closing for the lack of feedback and as it should be fixed.

Also available in: Atom PDF