Bug report #1282

"Update all" in "Legend items" broken

Added by Maciej Sieczka - almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:11342

Description

1. add 2 layers (any kind)

2. start print composer, add a map

3. add a legend, remove one of the layers from the "Legend items" list

4. press "Update all" in "Legend items" - the layer you removed in step 3. pops up back in the legend itself (corrupted - without a symbol), but not in the "Legend items".

missing_layer.png (29 KB) Maciej Sieczka -, 2008-09-07 06:48 AM

History

#1 Updated by Marco Hugentobler almost 12 years ago

Seems to work for me. The layer poping back is intended behaviour, because 'update all' means to re-read the whole composer legend settings.
When I tried it, the symbol was correct. Just the layer was not unfoldet. Could you make sure the symbol is really missing for you?

#2 Updated by Maciej Sieczka - almost 12 years ago

Replying to [comment:1 mhugent]:

Seems to work for me. The layer poping back is intended behaviour, because 'update all' means to re-read the whole composer legend settings.
When I tried it, the symbol was correct. Just the layer was not unfoldet. Could you make sure the symbol is really missing for you?

The bug is that if you remove a layer from "Legend items" and press "Update all" in "Legend items", the legend itself is updated OK, *but there is a missing layer in the "Legend items".

See the attached screendump - on the legend itself there are 2 layers - OK. But in the "Legend items" dialog there is only 1 of them - the 'wromap_A' is missing. Is this clear to you now?

(FTR, the missing symbol issue is no longer present.)

#3 Updated by Marco Hugentobler almost 12 years ago

Ok, It is now clear to me what you mean. Unfortunately, on my system both layer are shown in the legend and in the layer items after pressing 'update all'. Strange.

#4 Updated by Maciej Sieczka - almost 12 years ago

Replying to [comment:3 mhugent]:

Ok, It is now clear to me what you mean. Unfortunately, on my system both layer are shown in the legend and in the layer items after pressing 'update all'. Strange.

I see. One more thing I noticed: saving the project and reloading it corrects the problem.

Maybe it's about particular data? I'm attaching 2 shapefiles and a project with map composition ready to try to reproduce the problem.

#5 Updated by Maciej Sieczka - almost 12 years ago

The file is to big fro Trac. You can fetch it from here: http://www.sieczka.org/tmp/wromap.zip

#6 Updated by Marco Hugentobler almost 12 years ago

Still works for me with the attached data. I tried with both Qt-4.3.4 and Qt-4.4.1

#7 Updated by Maciej Sieczka - almost 12 years ago

Replying to [comment:6 mhugent]:

Still works for me with the attached data. I tried with both Qt-4.3.4 and Qt-4.4.1

Shoot. Maybe a QT issue? I'm using stock 4.4.0 on Debian testing amd64. Will try against self-built 4.4.1 after Friday.

#8 Updated by Maciej Sieczka - almost 12 years ago

Can you maybe try with 4.4.0 in the meantime?

#9 Updated by Paolo Cavallini over 11 years ago

Is this still valid? If not, please close it.

#10 Updated by Paolo Cavallini about 11 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Reopen it if necessary

Also available in: Atom PDF