Bug report #1278

Layer transparence in tif format fails

Added by Gerhard Spieles almost 12 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:ersts -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:11338

Description

geo-referenced tif images appears black when change transparence in layer properity.

qgis_transparenz_tif.pdf - transparency in layer properitiy and tif file is black (176 KB) Gerhard Spieles, 2008-09-03 02:12 PM

b_plan_fell_kortsfuhr.tfw (95 Bytes) Gerhard Spieles, 2008-09-22 01:47 PM

b_plan_klostergarten-geo.tfw (95 Bytes) Gerhard Spieles, 2008-09-22 01:49 PM

History

#1 Updated by Maciej Sieczka - almost 12 years ago

Can you attach a small example?

#2 Updated by ersts - almost 12 years ago

Hi gespiel! Sorry you are having problems.

geo-referenced tif images appears black when change transparence in layer properity.

To me the uniformly gray display, as shown in the PDF example, makes me think you need to apply an enhance or "stretch" to the image.

1) Does your tif look correct outside of QGIS?
2) When the transparency is 0% does your image look correct/as you expect?
3) How was your tif georeferenced? Did you use the QGIS plugin? (if yes, can you explain the setting you used)

Is it possible to post a copy of your tif?

#3 Updated by Gerhard Spieles almost 12 years ago

Hi,
outside Qgis, the tif-iamges look ok.
Attached are two tif images. Adding raster Layer without change trasparency, both images look ok in Qgis. Change transparence of the image b_plan_fell_kortsfuhr.tif is ok.
change tranparence in the rasterlayer of image b_plan_klostergarten-geo.tif, the image get grey, change agains to transparence 0%, the image get black.

#4 Updated by Gerhard Spieles almost 12 years ago

Sorry,
tif images are zip-compressed near 600 kB, so upload is not possible.
Can you tell me email ontact.

#5 Updated by ersts - almost 12 years ago

you can send them to ersts

at amnh.org

#6 Updated by ersts - over 11 years ago

  • Status changed from Open to In Progress

Can we get a confirmation that this is still a problem in the Version 1.0.0 release?

#7 Updated by Gerhard Spieles over 11 years ago

Hello Ersts,

thank for looking to the problem.
In Qgis 1.0, preview II, the problem is nearly solved. In "one Band color tifs", transparency of the white colour is shown in gray.
You can solve this by looking to the color-table and add the colour 0.0 (white) and 1.0 (grey) to the tranparent pixel list.

I couldnt test it on version 1.0 stabble, because the MSVC based build of QGIS terminates with a dll-fault in Windows. (i have Qgis strictly isntalled to the wiki.qgis.org installation guide)

#8 Updated by ersts - over 11 years ago

Replying to [comment:8 gespiel]:

In "one Band color tifs", transparency of the white colour is shown in gray.

I am sorry but I don't understand. If you change the layer's transparency, all colors will change. Is there a dark layer under the white region?

You can solve this by looking to the color-table and add the colour 0.0 (white) and 1.0 (grey) to the tranparent pixel list.

How many pixel values do you have? Is it just that you don't want 0 and 1 to be shaded?

#9 Updated by Paolo Cavallini over 11 years ago

Please gespiel, could you test again with 1.0.1? I cannot reproduce your problem, so it might have been fixed. If so, please close it.

#10 Updated by Paolo Cavallini over 11 years ago

According to our new bug policy, I'm closing this, pending feedback from the user. In case it is still valid, please reopen it. Sorry for the additional trouble.

#11 Updated by Paolo Cavallini over 11 years ago

  • Resolution set to invalid
  • Status changed from In Progress to Closed

Also available in: Atom PDF