Bug report #12774

Attribute table only show first 99 rows from SQL Server views

Added by Jason Moore about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20873

Description

Whenever I add a non spatial SQL Server layer from a view and check the attribute table there are only 99 rows returned. I have tried this on several views and on a local and server side DB with the same results.

History

#1 Updated by Jason Moore about 5 years ago

I was wrong, this behavior is not found from the local SQL Server db. I get all rows from the same views.

#2 Updated by Jason Moore about 5 years ago

Found that views return all rows if the setting Options->Data Sources->Attribute table row cache is set to anything but "All". When set to all attribute table returns 99 or 100 rows.

#3 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

Jason Moore wrote:

Found that views return all rows if the setting Options->Data Sources->Attribute table row cache is set to anything but "All". When set to all attribute table returns 99 or 100 rows.

do you mean "attribute table behavior" or "attribute table row cache"? does it happens for other datasources?

#4 Updated by Giovanni Manghi about 5 years ago

  • Category changed from Data Provider to Data Provider/MSSQL

#5 Updated by Jason Moore about 5 years ago

Attribute table cache. And I have found any other data sources that exhibit this behavior. Tried shp and dxf.

#6 Updated by Jason Moore about 5 years ago

Jason Moore wrote:

Attribute table cache. And I haven't found any other data sources that exhibit this behavior. Tried shp and dxf.

#7 Updated by Nathan Woodrow about 5 years ago

Do you still see this happening. I can't reproduce it here

#8 Updated by Jason Moore about 5 years ago

Still happens, only on non-spatial attribute tables (looks like only those that reference views in mssql) and only if Options->Data Sources->Attribute table row cache is set to all.

#9 Updated by Nathan Woodrow about 5 years ago

So just to check that is: non spatial tables which are views?

#10 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable

closing for lack of feedback.

#11 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF