Bug report #12763

Processing: GRASS r.horizon do not produce an output

Added by Paolo Cavallini almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Processing/GRASS
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:20862

Description

Both modules (*.height actually missed an output parameter)

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Assignee changed from Victor Olaya to Giovanni Manghi

#2 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

The module does not creates an output because it crashes (on both grass64 and grass7). Tested from the GRASS GUI/command line.

It didn't use to crash, but I can't exclude that eventually using this module in raster mode can't be used anymore to create just 1 raster output. The module in fact do not crash in raster mode when creating multiple output raster maps (by adding the "step" parameter), but in Processing multiple output raster maps are not supported, unless someone is willingly to add this as a special case in Grass(7)Algorithm.py

If it turns out that forcing just 1 output raster map is not supported by grass anymore then the module r.horizon should be removed. The other tool, the one that uses the "point" mode works fine (that outputs to stdout or a text file), at least on grass7/processing.

Also available in: Atom PDF