Bug report #12746

qgis 1:2.8.1-0+20trusty in ubuntugis unstable repository has unresolvable dependency with libgdal

Added by Andreas Wiesmann over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:20845

Description

The qgis version in the ubuntugis unstable repository has a dependency on libgdal.so.1-1.11.1 but the available version is 1.11.2 resulting in a apt-get error:

The following packages have unmet dependencies:
qgis : Depends: libgdal.so.1-1.11.1 but it is not installable

Snippets from http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/dists/trusty/main/binary-amd64/Packages:

Package: qgis
Priority: optional
Section: science
Installed-Size: 15534
Maintainer: QGIS developers <[email protected]>
Architecture: amd64
Version: 1:2.8.1-0+20trusty
Recommends: qgis-plugin-grass, qgis-plugin-globe, python-qgis
Suggests: gpsbabel
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libgdal.so.1-1.11.1, libgdal1h (>= 1.8.0), libgeos-c1 (>= 3.4.2), libgsl0ldbl (>= 1.9), libpq5, libproj0 (>= 4.8.0-1), libqgis-analysis2.8.1, libqgis-core2.8.1, libqgis-gui2.8.1, libqgis-networkanalysis2.8.1, libqscintilla2-11, libqt4-network (>= 4:4.6.1), libqt4-sql (>= 4:4.5.3), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libqtwebkit4, libqwt5-qt4, libspatialite5 (>= 2.4.0), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 4.4.0), qgis-providers (= 1:2.8.1-0+20trusty), qgis-common (= 1:2.8.1-0+20trusty)
Conflicts: uim-qt3
Filename: pool/main/q/qgis/qgis_2.8.1-0+20trusty_amd64.deb
Size: 5103428
MD5sum: 7377fb04ff96fa0c37dce2b4f3772717
SHA1: 737afbfa690fa6fb5f2c24e45e3f7598c6c0e65a
SHA256: 73d8c6e3ed87c36e3f63cb15c9ca63ec61e8a7ed09bcd24bc1979e22c13af05d
Description: Geographic Information System (GIS)
Description-md5: 49f76973cc4c2bd4a16872b7a79659ad

Package: libgdal-dev
Source: gdal
Priority: optional
Section: libdevel
Installed-Size: 28250
Maintainer: Debian GIS Project <[email protected]>
Architecture: amd64
Version: 1.11.2+dfsg-1~exp2~trusty
Replaces: libgdal1-dev (<< 1.9.0-1~)
Suggests: libgdal-doc
Depends: libgdal1h (= 1.11.2+dfsg-1~exp2~trusty), libc6-dev, libnetcdf-dev, libjasper-dev, libpng-dev, libjpeg-dev, libgif-dev, libwebp-dev, libhdf4-alt-dev, libhdf5-dev, libpq-dev, libxerces-c-dev, unixodbc-dev, libsqlite3-dev, libgeos-dev, libmysqlclient-dev, libltdl-dev, libcurl4-gnutls-dev | libcurl-ssl-dev, libspatialite-dev, libdap-dev
Breaks: libgdal1-dev (<< 1.9.0-1~)
Filename: pool/main/g/gdal/libgdal-dev_1.11.2+dfsg-1~exp2~trusty_amd64.deb
Size: 4726800
MD5sum: 9dac77fd740a9a79819f4d8acd313fa5
SHA1: e3759587c6eb9ef1a760ef63f8f00f15939fa97b
SHA256: 49ff014071da0526dd65c17dc9a564b25a446e2598ef2759353e8ad5740416a0
Description: Geospatial Data Abstraction Library - Development files
Description-md5: fe1355584b1a93438b3699e1581cff4b

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

Please use 2.8.2 from our ubuntugis repository at http://qgis.org/ubuntugis (see Debian/Ubuntu on the download page).

Also available in: Atom PDF