Bug report #12734

QGis crashes when deleting last vertex of a postgis MultiLineString part

Added by Christophe Damour about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.8.1 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:20834

Description

QGis crashes when I try to delete the last vertex of a postgis MultiLineString part.

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Category changed from Edit widget to Digitising
  • Status changed from Open to Feedback

Cannot confirm on qgis master on Linux.

#2 Updated by Christophe Damour about 5 years ago

Giving it another try, I can only reproduce it when I delete the last vertex of the last part of the MultiLineString.

#3 Updated by Giovanni Manghi about 5 years ago

Christophe Damour wrote:

Giving it another try, I can only reproduce it when I delete the last vertex of the last part of the MultiLineString.

I tested also this scenario, no crash on QGIS master/Linux.

#4 Updated by Christophe Damour about 5 years ago

Testing it further on Ubuntu QGis 2.8.2 with fresh PostGis vector layers, I couldn't reproduce the crash...
So it might be related to my vector layer. I'll check it soon and let you know.

#5 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

reopen if necessary.

Also available in: Atom PDF