Bug report #12727

Openstreetmap Import to spatialite incomplete

Added by Andre Joost about 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:20827

Description

From the QGIS user mailing list http://osgeo-org.1560.x6.nabble.com/OSM-data-gaps-td5204902.html and http://osgeo-org.1560.x6.nabble.com/Open-street-map-td5204901.html

Zoom to New York with this extent:
xMin,yMin -74.2907;40.5931 : xMax,yMax -73.8504;40.7827

Vector -> Openstreetmap -> Download, then import, then export to spatialite only Polylines

displays 37602 lines.

Using Add vector Layer (or drag and drop) on the same imported .osm file creates 53607 lines, ogr2ogr as well.

As a reference, osm2pgsql into a postgis database creates even 59667, maybe due to different handling of incomplete multipolygon relation members.


Related issues

Related to QGIS Application - Bug report #10790: OpenStreetMap plugin only loads 32 bits numbers ID, then ... Closed 2014-07-03
Duplicates QGIS Application - Bug report #8878: OSM plugin fails to download all data within given extent Closed 2013-10-16

History

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Andre Joost about 3 years ago

Maybe related #10790

#4 Updated by Jürgen Fischer about 3 years ago

  • Related to Bug report #10790: OpenStreetMap plugin only loads 32 bits numbers ID, then start with negative numbers added

#5 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Closed

OSM downloader has been removed for 3.0

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to wontfix
  • Description updated (diff)

Also available in: Atom PDF