Bug report #12656

Style Manager filter ignores currently selected group

Added by Spencer Gardner over 5 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20769

Description

I have created a new group in Style Manager and populated it with some styles. When I filter the symbols in my group using the filter box, the results return matches from all ungrouped and grouped styles, even styles that are assigned to a different group than the one I'm looking at. The filter should operate only on the group selected.

Steps to reproduce:
1) Open Style Manager
2) Create a new group
3) Create a new line style called "test road"
4) Assign "test road" to the new group
5) Select the new group
6) In the filter box type "road"

The results include road styles from the ungrouped styles as well as any matches from other groups. Should only show "test road" since this is the only match in the new group.

History

#1 Updated by Pirmin Kalberer over 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Tracker changed from Support to Bug report
  • Project changed from QGIS Redmine (QGIS bug tracker) to QGIS Application
  • Affected QGIS version set to 2.8.1

#2 Updated by Jürgen Fischer over 5 years ago

  • Category set to Symbology

#3 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#4 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to fixed/implemented
  • Description updated (diff)
  • Status changed from Open to Closed

Fixed in master

Also available in: Atom PDF