Bug report #12647

qgis 2.8.1 – processing gdal 1.11.2 error/processing GRASS error (mac, 10.10.3)

Added by Bruce Atkinson almost 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:2.8.1 Regression?:No
Operating System:OsX Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20760

Description

I'm getting an error when using either GDAL or GRASS in the ToolBox (see GDAL.tiff, GREASS.tiff). The complete logs are in GDAL log.rtf and GRASS log.rtf. I tried installing QGIS 2.8.1 on another Mac that had a freshly reformatted HD as well as clean install of Yosemite 10.10.3 and ran into the same problem.

GDAL_log.rtf - GDAL Error Message (6.25 KB) Bruce Atkinson, 2015-04-26 12:18 PM

GDAL_log.rtf - GDAL Log (6.25 KB) Bruce Atkinson, 2015-04-26 12:18 PM

GRASS.tiff - GRASS Error Message (96.1 KB) Bruce Atkinson, 2015-04-26 12:18 PM

GRASS_log.rtf - Grass Log (13 KB) Bruce Atkinson, 2015-04-26 12:18 PM

Lumps_2013.dbf (1.23 MB) Bruce Atkinson, 2015-04-26 01:23 PM

Lumps_2013.prj (143 Bytes) Bruce Atkinson, 2015-04-26 01:23 PM

Lumps_2013.qpj (257 Bytes) Bruce Atkinson, 2015-04-26 01:23 PM

Lumps_2013.shp (30.9 KB) Bruce Atkinson, 2015-04-26 01:23 PM

Lumps_2013.shx (8.89 KB) Bruce Atkinson, 2015-04-26 01:23 PM

Displace.tiff (105 KB) Bruce Atkinson, 2015-04-27 03:48 AM

displaced.rtf (2.27 KB) Bruce Atkinson, 2015-04-27 03:48 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Category set to 94
  • Status changed from Open to Feedback

Please detail the modules you are trying to run and if possible attach sample of your inputs.

#2 Updated by Bruce Atkinson almost 5 years ago

The models are shown in the log files, specifically for GDAL Algorithm Grid (Inverse distance to a power) and for GRASS Algorithm v.surf.idw - Surface interpolation from vector point data by Inverse Distance Squared Weighting. The input is attached.

#3 Updated by Giovanni Manghi almost 5 years ago

  • Operating System set to OsX

I cannot test on OsX as I don't have such platform (or know anyone that could allow me to try), but on Linux and Windows both modules are ok with your input data.

#4 Updated by Bruce Atkinson almost 5 years ago

Thanks for testing!!

Perhaps it's a Mac thing. I'm not the only one with a problem, at least for GDAL; see http://www.faqssys.info/qgis-2-8-1-processing-gdal-1-11-2error-mac-10-10-2/

There may be more generic issues.

#5 Updated by Bruce Atkinson almost 5 years ago

GDAL is working (sort of). The output is displaced from the data as per 'Displace.tiff'. The associated log is 'displaced.rtf'. Note in the log that the corner coordinates are properly identified (Corner coordinates = (60.758630 57.695719)(-46.899704 42.762614)). The CRS is WG84 in all cases.

Grass is still not working.

#6 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Feedback to Open

#7 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

#8 Updated by Alexander Bruy about 4 years ago

  • Status changed from Open to Feedback

Still true with 2.14?

#9 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable

closing for lack of feedback. Please reopen if necessary.

#10 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF