Bug report #12643

Processing convex hull does not work

Added by Giovanni Manghi over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20756

Description

In the latest Processing the QGIS Convex Hull does not create any output. In the log the message

2015-04-24T16:25:40 1 Feature geometry not imported (OGR error: Pointer 'hGeom' is NULL in 'OGR_G_ImportFromWkb'.
)

shows.

It worked in the Processing version shipped with QGIS 2.6.1

Tested on 2.8.1 and master on Windows and Linux.

See also #12639 that on my machines I cannot confirm.

localidades.dbf.zip (83 KB) Giovanni Manghi, 2015-04-29 11:48 AM

Associated revisions

Revision 71fa5d41
Added by Alexander Bruy about 5 years ago

[processing] fix Convex Hull algorithm (fix #12643)

Revision e4b0f788
Added by Alexander Bruy about 5 years ago

[processing] fix Convex Hull algorithm (fix #12643)

History

#1 Updated by Victor Olaya over 5 years ago

  • Status changed from Open to Feedback

cannot reprocude it in here, but it looks like it's a problem with your layer. Can you share it?

#2 Updated by Giovanni Manghi over 5 years ago

here it fails with any input, test attached point shapefile

#3 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#4 Updated by Alexander Bruy about 5 years ago

  • Status changed from Open to Closed

#5 Updated by Alexander Bruy about 5 years ago

  • Resolution set to fixed/implemented

Also backported to 2.8

Also available in: Atom PDF