Bug report #12617

Join without caching do not work with Spatialite tables

Added by Admire Nyakudya over 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20735

Description

I have two layers loaded in qgis called list(non spatial) and structure (spatial) all coming from spatialite. Creating a join between the layers only works when the join is cached. When I create the join as non cached the join does not work as it appends to the first attribute in the table I am joining to. I have tested with layers coming from Postgres and it works well. I have tested this behavior in both Ubuntu 14.10 and windows 7.

non_cache_error.png (66 KB) Admire Nyakudya, 2015-04-21 06:36 AM

cached_join.png (49.3 KB) Admire Nyakudya, 2015-04-21 06:36 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.8.1 to master
  • Subject changed from spatialite dynamic join to Join without caching do not work with Spatialite tables
  • Target version changed from Version 2.8.1 to Version 2.8.2
  • Operating System deleted (Ubuntu )
  • OS version deleted (14.10)

Confirmed on master too. Seems like it never worked as expected (tested down to 2.0.1).

#2 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#3 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.10)

#4 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Is this still reproducible on current master? I can't replicate it

#5 Updated by Admire Nyakudya over 4 years ago

I have tested in current master and it is fixed. Has it been back ported to 2.14 yet because i still see the error in 2.14.1

#6 Updated by Nyall Dawson over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Unsure about 2.14. I'll backport a bunch of possibly related fixes and hopefully it will include the change which fixed this.

Also available in: Atom PDF