Bug report #12546

Rotate tool not availlable when using rules and svg symbology

Added by Arnold Huisman about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20688

Description

When using rulebased styles in combination with a data defined angle for a svg symbol, the rotate tool is not availlble for the layer. My current workaround is to use a slider field to set the correct angle of the data defined field. This is cumbersome and error-prone. Also the map is not updated correctly right away, making it very hard to see the angle of an icon.

The best solution would be to allow for data defined angles in the rulebased style, just like the other styles. I'm assuming the rotate tool will work fine then.

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 2.8.1 to Version 2.8.2

#2 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#3 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #12123

Also available in: Atom PDF