Bug report #12543

layer style effects not compatible with inverted polygon renderer

Added by Regis Haubourg over 4 years ago. Updated over 1 year ago.

Status:Reopened
Priority:Low
Assignee:Nyall Dawson
Category:Symbology
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20685

Description

Hi,
just tested wonderfull live layer effects, and that reveals not taking into account inverted polygon renderer.
Polygons are rendered just as normal polygon renderer.

We use it a lot to generate masking layers effects (see mask plugin).

Cheers
Régis

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Can you clarify this for me? When I test, this is what I see:

- inverted polygon, symbol layer effect: works
- inverted polygon, layer wide effect: results in no layer drawn

#2 Updated by Regis Haubourg over 4 years ago

  • Status changed from Feedback to Closed

Sorry, I missed that it was available on both levels.. Maybe UI needs to separate checkbox a bit more.

#3 Updated by Nyall Dawson over 4 years ago

  • Status changed from Closed to Reopened

Don't close this - there is a bug, because layer wide effects aren't working with the inverted renderer

#4 Updated by Martin Dobias over 4 years ago

  • Priority changed from Severe/Regression to Normal

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Regis Haubourg over 1 year ago

  • Affected QGIS version changed from 2.8.1 to 3.0.0
  • Description updated (diff)
  • Priority changed from Normal to Low

Still true in master

Also available in: Atom PDF