Bug report #12501

QGIS does consistantly display all features of ESRI .shp files on Map

Added by Robert Slivinsky over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20647

Description

QGIS fails to render all features of ESRI .shp files on the map canvas. Not sure if this is related to larger data sets, but if I add an ESRI .shp file of property parcels, not all parcels show up on the map. The exact same data set in Mapinfo .TAB show up just fine. Please see the attached images. One is a shp (showing only a few features) and the other is a tab (showing all features). I have noticed this issue the last few years (since I have been using it) and am finally reporting it. This type of error may scare new users away as it is basic/core functionality that does not work properly.

Thank You.

shp.png (2.9 MB) Robert Slivinsky, 2015-04-02 05:03 AM

tab.png (2.96 MB) Robert Slivinsky, 2015-04-02 05:03 AM

History

#1 Updated by Nathan Woodrow over 4 years ago

Can you attach the shapefile?

#2 Updated by Robert Slivinsky over 4 years ago

Nathan, it is a large file. Can I send it to you via WeTransfer.com?

#3 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

we have seen this issue many times here, and in most of cases it was a faulty spatial index. Try remove the indexes files and rebuild a new one using the proper button in vector properties.

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF