Bug report #12498

Python console crash QGIS if undocked while autocompletion active

Added by Roy Roge over 4 years ago. Updated 9 months ago.

Status:Closed
Priority:High
Assignee:-
Category:PyQGIS Console
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:20644

Description

Step to reproduce:
  • open python console
  • start writing a line so that the auto completion menu opens
  • without choosing any entry undock the python console (the auto completion menu is still open)
  • left click into the console leads QGIS to crash.

best, Roy.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from Normal to High

#2 Updated by Matthias Kuhn over 3 years ago

Does not seem to be an easy fix.

I think it boils down to this upstream bug report:
https://bugreports.qt.io/browse/QTBUG-22605

Removing `Qt::WA_StaticContents` should resolve the crash, but as far as I can see, this flag is set internally by QScintilla we don't actually use it a lot in QGIS.

The upstream report mentions that "the crash is no longer reproducible" without more details, so we can only assume that it has been resolve in Qt in some release of the 5-series...

#3 Updated by Matthias Kuhn over 3 years ago

Apparently not... QGIS with Qt 5.6 crashes as well.

#4 Updated by Giovanni Manghi over 2 years ago

  • Target version set to Version 3.0
  • Affected QGIS version changed from 2.8.1 to master

#5 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#7 Updated by Nyall Dawson 9 months ago

  • Resolution set to no timely feedback
  • Description updated (diff)
  • Status changed from Feedback to Closed

Also available in: Atom PDF