Bug report #12485

Modeler calculator error

Added by Paolo Cavallini over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20633

Description

When adding a sample calculation in the Modeller calculation (e+2*h), I get:

Traceback (most recent call last):
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerDialog.py", line 401, in addAlgorithm
self._addAlgorithm(alg.getCopy())
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerDialog.py", line 420, in _addAlgorithm
self.repaintModel()
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerDialog.py", line 350, in repaintModel
self.scene.paintModel(self.alg)
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerScene.py", line 89, in paintModel
item = ModelerGraphicItem(alg, model)
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerGraphicItem.py", line 57, in init
self.pixmap = element.algorithm.getIcon().pixmap(15, 15)
File "/home/paolo/.qgis2/python/plugins/processing/modeler/ModelerAlgorithm.py", line 105, in algorithm
self._algInstance = ModelerUtils.getAlgorithm(self.consoleName).getCopy()
AttributeError: 'NoneType' object has no attribute 'getCopy'

Versione Python:
2.7.9 (default, Mar 1 2015, 13:01:26)
[GCC 4.9.2]

Versione di QGIS:
2.8.1-Wien Wien, exported


Related issues

Related to QGIS Application - Bug report #11539: Processing modeller: calculation parameters lost Closed 2014-11-04

History

#1 Updated by Paolo Cavallini over 5 years ago

  • Subject changed from Molerrer calculator error to Modeler calculator error

#2 Updated by Victor Olaya almost 5 years ago

  • Status changed from Open to Feedback

Can you confirm this is still an issue?

I am not able to reproduce it. A model that uses the raster calculator (the saga one) seems to be working fine now

#3 Updated by Victor Olaya almost 5 years ago

ok, i see that you were refering to the modeler-only calculator. Just tested and it seems to work fine too. Can you confirm?

#4 Updated by Paolo Cavallini almost 5 years ago

  • Status changed from Feedback to Closed

Agreed, seems to be working fine now.

Also available in: Atom PDF