Bug report #12476

Manual legends in composer from 2.4 and older are reset in 2.6 and >

Added by Regis Haubourg over 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:20624

Description

manually modified legends in composers made in 2.4 or older versions are reset in 2.6 versions and older.
That breaks a lot a maps where legend is often a big piece of work.
This is related to legend refactoring.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#2 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.10)

#3 Updated by Jürgen Fischer over 4 years ago

  • Assignee deleted (Martin Dobias)

#4 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Open to Feedback

This looks like very much one of those tickets that no one will ever fix.

What is the status? Can we close?

#5 Updated by Nyall Dawson almost 4 years ago

I'd say given the age of 2.4 we can safely close this now.

#6 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to wontfix

#7 Updated by Regis Haubourg almost 4 years ago

agreed with Nyall, the problem is still there but migration process is probably done for most users.
cheers
Régis

Also available in: Atom PDF