Bug report #12423

Processing - Bar Plot (QGIS) doesn't plot string "category name field"

Added by Luca Lanteri over 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20595

Description

Using the attached data, plot test2 with "nome" as Category name field and "shape_area" as value field.
All bar plot category are "none".

test2.zip (59.7 KB) Luca Lanteri, 2015-03-21 01:54 AM

test.html.png (12 KB) Luca Lanteri, 2015-03-21 01:54 AM

History

#1 Updated by Luca Lanteri over 5 years ago

Same problem with "mean and standard deviation plot". It works with numeric value.

#2 Updated by Giovanni Manghi over 5 years ago

  • Operating System deleted (Mint)
  • OS version deleted (17)
  • Affected QGIS version changed from 2.8.1 to master

#3 Updated by Alexander Bruy about 5 years ago

How you can draw plot when both fields (mean and stddev, name and value) contains strings or dates?

#4 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

#5 Updated by Luca Lanteri about 5 years ago

Maybe I miss something. What kind of feedback is needed ?

Thanks
Luca

#6 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

still valid on master.

#7 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Feedback

I don't think this is a bug. To plot we need two sets of numbers: one for X values and second for Y. How we can create plot if X or Y values are strings?

I can change algorithms to disable non numeric fields, if this helps.

#8 Updated by Alexander Bruy over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Fixed in master

Also available in: Atom PDF