Bug report #12414

Cannot change Filter

Added by Paul Mellon over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20586

Description

Adding new MSSQL layer, setting a filter, all OK.
After adding, cannot alter the filter. Also show object count gives [0].
This used to work fine in 2.2, but 2.6 and 2.8 it no longer works.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Target version set to Version 2.10
  • Priority changed from Normal to Severe/Regression

#2 Updated by Jürgen Fischer over 4 years ago

  • Target version changed from Version 2.10 to Future Release - High Priority

#3 Updated by Giovanni Manghi over 4 years ago

  • Subject changed from MS SQL Layer cannot change Filter to Cannot change Filter
  • Category changed from Data Provider/MSSQL to Vectors
  • Affected QGIS version changed from 2.8.1 to master
  • Operating System deleted (Windows 7 64-bit, MS SQL Server 2012)

I have just hit the same problem, but with a PostGIS layer.

It happened on a project made with an old version of qgis (probably 2.2).

When trying to remove the filter I get

An error occurred when executing the query.
The data provider said:
no result buffer
no result buffer

#4 Updated by Alessandro Pasotti over 4 years ago

Cannot reproduce in current master. Tested with postgis on a new project.
I think we need a test project and a step-by-step procedure to reproduce.

#5 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

it seems to work fine on qgis master, please reopen if necessary.

Also available in: Atom PDF